Hosting

Algemene informatie over de PHP upgrade


Op dit moment ondersteunt het platform van XS4ALL PHP versie 5.6, 7.0 en 7.3. Nog in 2019 stopt de ondersteuning van PHP versie 5.6.

Lees hier waar u op moet letten tijdens een PHP upgrade en welke applicaties wel en niet geschikt zijn voor bepaalde PHP versies. Zo kunt u zien of uw site up-to-date is en u klaar bent voor de komende wijzigingen.

Waarom deze upgrade?

PHP versie 5.6 is een oude versie die niet meer wordt ondersteunt. Ook de
veiligheidsupdates zijn eind 2018 gestopt. Als er een veiligheidsprobleem ontstaat, dan wordt dit niet meer opgelost. Om ervoor te zorgen dat uw website goed en veilig blijft draaien raadt
XS4ALL aan op de upgraden naar minimaal PHP versie 7.0. .


Wat kan dit voor u betekenen?

Uw website moet geschikt zijn voor PHP 7.0. In vergelijking met oudere PHP
versies zijn in nieuwe versies bepaalde functies verdwenen, aangepast
of nieuwe functies toegevoegd. Het kan daarom gebeuren dat uw website na
de update vanaf versie 7.0 niet meer functioneert zoals u dat gewend
bent.

  • Heeft uw website de afgelopen twee jaar geen update gehad? Dan is het goed mogelijk dat de site niet volledig geschikt is voor recente PHP versies. Verder op deze pagina geven wij informatie waar mee u kunt nagaan of uw website momenteel geschikt is voor de
    upgrade. 

  • Heeft u een webshop in uw website, controleer de werking daarvan dan goed. Als uw webshop niet geschikt is voor PHP 7.0, dan zal deze zeer waarschijnlijk niet meer goed
    functioneren na de upgrade. Wij raden u daarom aan uw webshop altijd te
    updaten naar de meest recente versie. De kans is dan zeer groot dat uw
    webshop wél compatible is en zal blijven bij verdere toekomstige PHP
    upgrades.

  • Maakt u gebruik van een CMS (Content Management Systeem) zoals Wordpress, Joomla, Drupal, of een vergelijkbaar CMS? Controleer dan of de door u gebruikte versie geschikt is voor de meest recente PHP versie. Vooral bij CMSen geldt dat wij adviseren om deze altijd zo up-to-date mogelijk te houden. Dit is ook voor de veiligheid van uw
    website zeer belangrijk!

Is uw website door u zelf of een webbouwer ontwikkeld, dan is het belangrijk om na te kijken of er in de website nog gebruik gemaakt wordt van PHP-code die in de nabije toekomst
en/of bij volgende upgrades niet meer ondersteund wordt. Deze
zogenaamde “deprecated functies” worden nu in PHP nog ondersteund, maar
later niet meer.

Hoe wijzig ik zelf de PHP versie?

U kunt zelf de PHP versie wijzigen via Mijn XS4ALL. Als u de versie heeft gewijzigd, kunt u direct de website testen. Werkt de website niet goed? Zet de versie dan tijdelijk terug. U website blijft dan werken terwijl u naar een oplossing voor het probleem in de
website blijft werken.

chevron-down