Waarmee kunnen
wij u helpen?

Terug naar Klantenservice

PHP 5.3 naar PHP 5.5 upgrade

In 2014 ondersteunen wij voor alle Unix Webhosting Pakketten van XS4ALL zowel PHP 5.3 als PHP 5.5. Lees hier waar u op moet letten tijdens een PHP upgrade en welke applicaties wel en niet geschikt zijn voor bepaalde PHP versies. Zo kunt u zien of uw site up-to-date is en u klaar bent voor de komende wijzigingen.

Waarom deze upgrade?

Ons huidige webhosting platform maakt nu gebruik van PHP 5.3 en PHP 5.5. PHP versie 5.3 wordt ter zijner tijd uitgefaseerd als hier geen updates en patches meer voor uitkomen. Oude PHP versies die niet meer ondersteund worden, worden onveilig en moeten daarom up-to-date gehouden worden door middel van versie upgrades. Dit doen wij zodat wij veiligheid, continuïteit en performance kunnen garanderen.

Applicaties

Het up-to-date houden van binnen websites gebruikte applicaties zoals Content Management Systemen schiet er vaak bij in. “Waarom iets aanpassen als het werkt” horen we vaak. Echter, een applicatie zoals een CMS kan net zo vatbaar zijn voor veiligheidslekken als software op uw eigen PC. En uw website is voor het hele internet bereikbaar, dus de noodzaak voor updates is hier zelfs extra groot. Vergelijk het met de virusscanner op uw computer die zijn waarde snel zou verliezen zonder automatische updates.

Uiteraard nemen wij alle mogelijke maatregelen (laatste updates, patches en overige specifieke aanpassingen) om de veiligheid van het platform zo goed mogelijk te garanderen. Dit neemt niet weg dat er ook een grote verantwoordelijkheid bij de beheerder van de website ligt om -net als op de PC thuis- veiligheidsmaatregelen te treffen door altijd de laatste versie te gebruiken van applicaties binnen de website.

Wat kan dit voor u betekenen?

Uw website moet geschikt zijn voor PHP 5.3 of PHP 5.5. In vergelijking met oudere PHP versies. zijn in deze nieuwe versies bepaalde functies verdwenen, aangepast of nieuwe functies toegevoegd. Het kan daarom gebeuren dat uw website na de update naar PHP 5.3 of PHP 5.5 niet meer functioneert zoals u dat gewend bent. Heeft uw website de afgelopen twee jaar geen update gehad? Dan is het goed mogelijk dat de site niet volledig geschikt is voor recente PHP versies. Verder op deze pagina geven wij informatie waar mee u kunt nagaan of uw website momenteel geschikt is voor de upgrade.

Heeft u een webshop in uw website, dan moet u daar goed naar kijken. Als uw webshop niet geschikt is voor PHP 5.3 of PHP 5.5, dan zal deze zeer waarschijnlijk niet meer goed functioneren na de upgrade. Wij raden u daarom aan uw webshop altijd te updaten naar de meest recente versie. De kans is dan zeer groot dat uw webshop wél compatible is en zal blijven bij verdere toekomstige PHP upgrades.

Maakt u gebruik van een CMS (Content Management Systeem) zoals Wordpress, Joomla, Drupal, of een vergelijkbaar CMS? Controleer dan of de door u gebruikte versie geschikt is voor de meest recente PHP versie. Vooral bij CMSen geldt dat wij adviseren om deze altijd zo up-to-date mogelijk te houden. Dit is ook voor de veiligheid van uw website zeer belangrijk!

Is uw website door u zelf of een webbouwer ontwikkeld, dan is het zaak om na te (laten) kijken of er in de website nog gebruik gemaakt wordt van PHP-code die in de nabije toekomst en/of bij volgende upgrades niet meer ondersteund wordt. Deze zogenaamde “deprecated functies” worden nu in PHP 5.3 nog ondersteund, maar later dus niet meer. Om welke functies het gaat leest u op PHP.net: PHP 5.3 en PHP 5.5.

Indien u uw website herziet voor het gebruik van PHP versie 5.3, dan is het ook raadzaam om vast onderzoek te doen naar de wijzigingen voor PHP 5.5. Versie 5.5 van PHP is ook al een enige tijd beschikbaar en zal later ook als standaard gaan gelden. Dit omdat we u altijd van de nieuwste versies willen blijven voorzien. Echter gaan dan hier grotere wijzigingen mee gemoeid, dus voor de toekomst loont het om ook hier alvast rekening mee te houden.

Niet gevonden? Neem contact met ons op

Klantenservice en Technische ondersteuning: 020 398 76 66

Klantenservice

Werkdagen 8:00 - 20:00 uur
Zaterdag 10:00 - 17:00 uur

De Klantenservice is gesloten

Technische ondersteuning

Dagelijks 8:00 - 22:00 uur

De Helpdesk is gesloten

InternetVraagbaak: 020 398 70 07

Voor al uw internet vragen

Dagelijks 8:00 - 22:00 uur

Modem bij contractverlenging:
geavanceerde FRITZ!Box 7360

  • Eersteklas draadloos modem t.w.v € 249
  • Geschikt mee te bellen met vaste telefoon
  • Levenslange garantie
FRITZ!Box 7360
Menu Zoeken